Personal tools
You are here: Home Forum Use Re: Salome stalls at 38% when I try to compute the mesh

Re: Salome stalls at 38% when I try to compute the mesh

Up to Use

Re: Salome stalls at 38% when I try to compute the mesh

Posted by Sebastián H. Agudelo Sánchez at Wednesday 01:34

Hello everyone, i'm new to salome

I built my 3d model in solidworks and exported it in .step format to salome.

 

When I compute the mesh, it reaches 38% and does not advance any further, if I cancel the mesh calculation I get some errors related to the edges of the model, (errors and 3d cad in the link.)

Somebody could help me?

 

thanks in advance.

 

https://www.mediafire.com/file/6o60chnasbt96gb/salome1.0.rar/file

Re: Salome stalls at 38% when I try to compute the mesh

Posted by Franco Otaola at Wednesday 10:08

hello, 

actually salome is working eventhought the % is not increasing, I would say that your "issue" is that you have not waited enought or that your mesh is too fine.... I have seen these behavior of staying at 38% exactly (do not rememer if with mefisto or netgen....) but Is a matter of time only.... I do not understand completly why this happens as when you look at your processes, for example with htop, there are times where salome does not consume almost no ram, and no processor, I can imagine that there are some bottle necks in the algorithms that do not consume a lot of ressources but they also take a lot of time..... renumbering mesh maybe? or something like that.... (I am guessing, i have no idea why.) 

in any case, it is a normal behavior, and when you cancel it you get an error, is also normal as you did not finish of computing the mesh.

try reducing the mesh size, (or changing the algorithm, use for 2D mefisto, it takes less memory and is faster.... it might help you....)

 

best regards,

franco

Re: Salome stalls at 38% when I try to compute the mesh

Posted by Sebastián H. Agudelo Sánchez at Wednesday 22:45

Thank you very much Franco, indeed I am using netgen and when I check the ram usage it is very low as you say. I will try to lower the resolution of the mesh and switch to mefisto.

again thank you very much and if I have more problems I will comment.

Re: Salome stalls at 38% when I try to compute the mesh

Posted by Franco Otaola at Thursday 10:07

I just meshed correctly your geometry (I stayed in 2D at least, but if 2D works it should be fine for 3D only take more time)
and 2D mefisto default, 1D wire discretization with local length 0.035 equal to  and the mesh is created without any issue.

 

Previously Sebastián H. Agudelo Sánchez wrote:

Thank you very much Franco, indeed I am using netgen and when I check the ram usage it is very low as you say. I will try to lower the resolution of the mesh and switch to mefisto.

again thank you very much and if I have more problems I will comment.

 

Powered by Ploneboard
Document Actions