Personal tools
You are here: Home Forum Use Issue with Creating Groups on a STP model

Issue with Creating Groups on a STP model

Up to Use

Issue with Creating Groups on a STP model

Posted by Felipe Loo at March 09. 2021


I have a STEP model, and I am trying to create groups (i.e. patches) on this model using the Geometry module available in Salome. Basically, I am trying to add these groups in such a way that each group would be listed under the solid model in one sub-level. However, when I tried to create these groups, for some unknown reason these groups are created and placed on different sub-levels, as shown in the attached screenshot.

To be more specific, in the screenshot, you can see the solid model named "Solid 1". When I created the first group, named "wall", it was placed under "Solid1". Then, then when I tried to create a second group, named "outletA", it was placed under another sublevel named "Generic_SOLID" under "Solid1", which was automatically created when I imported the model. Then, when I created another group named "outletB", it's placed under the same level as "wall". When I tried to create another group, it's placed in another sub-level.

Is there a way to force all the groups to be under the same sub-level like "wall" and "outletB".

I am using latest version of Salome in Ubuntu.

Any suggestion would be greatly appreciated.




Re: Issue with Creating Groups on a STP model

Posted by Franco Otaola at April 07. 2021


i have not experienced this issue,

1. open geometry module
2. import step (it will show it without any sub level)
3. new entity/group/create group
4. select shape type:surface
5. select main shape: the imported body
6. click in the surface you want to add to the group -right clik)
7. change the name of the group in name
8. click "add" and apply
9. repeat for each group you want

this should give all same "sub level" groups and you should not have any problem.

Powered by Ploneboard
Document Actions