Personal tools
You are here: Home Forum Install & build Error messages when building Salome 8.5.0 in CAELinux 2017/4

Error messages when building Salome 8.5.0 in CAELinux 2017/4

Up to Install & build

Error messages when building Salome 8.5.0 in CAELinux 2017/4

Posted by Hélio C. Bortolon at August 21. 2018

Dear colleagues,

I am trying to compile Salome 8.5.0 in CAELinux 2017, based on XUbuntu 16.04, and I am getting a constant flow of error messages relating to a plethora of environment variables and file not found

I followed the instructions of README, but nothing was given about CONFIGURATION_ROOT_DIR and, after that being set, I fell in another error about not found files.

Please, could anyone give me a hint of how, really, could the sources of Salome 8.5.0 be compiled? What I have to set before going to the instructions available?

"""

cmake -DCONFIGURATION_ROOT_DIR=/home/heliocb/Downloads/temp/salome-8.5.0/KERNEL_SRC_8.5.0 -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/home/heliocb/salome /home/heliocb/Downloads/temp/salome-8.5.0/KERNEL_SRC_8.5.0
CMake Error at CMakeLists.txt:44 (INCLUDE):
  include could not find load file:

    SalomeMacros


CMake Error at CMakeLists.txt:51 (INCLUDE):
  include could not find load file:

    SalomeSetupPlatform


CMake Error at CMakeLists.txt:87 (FIND_PACKAGE):
  By not providing "FindSalomePythonInterp.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "SalomePythonInterp", but CMake did not find one.

  Could not find a package configuration file provided by
  "SalomePythonInterp" with any of the following names:

    SalomePythonInterpConfig.cmake
    salomepythoninterp-config.cmake

  Add the installation prefix of "SalomePythonInterp" to CMAKE_PREFIX_PATH or
  set "SalomePythonInterp_DIR" to a directory containing one of the above
  files.  If "SalomePythonInterp" provides a separate development package or
  SDK, be sure it has been installed.


-- Configuring incomplete, errors occurred!
"""

Re: Error messages when building Salome 8.5.0 in CAELinux 2017/4

Posted by Hélio C. Bortolon at August 21. 2018

All right, I figure out an error of myself, the CONFIGURATION_ROOT_DIR, fixed absences of SWIG, LIBXML2 and LIBHDF5 'dev' libraries.

The problems are getting deep into the system, with the Synaptic being unable to update and install a lot of needed packages because of 'broken package' problems.

Thank you all.

Powered by Ploneboard
Document Actions