Personal tools
You are here: Home Forum Install & build Install From Binaries: Ubuntu 17.10

Install From Binaries: Ubuntu 17.10

Up to Install & build

Install From Binaries: Ubuntu 17.10

Posted by CSMDakota at May 12. 2018

Hi All, 

Interested in trying out SALOME, having problems getting the application installed on Ubuntu 17.10.   I ran from the latest binaries; at the end of the install, or if I run ./create_appli.sh I recieve the following:

=======================================

Self Extracting Salome V8_4_0 Installer

=======================================

Enter the Salome install directory [default=/home/csmdakota/salome] : 

Salome is in English, do you want to be in French ? [y/N] : n

Installation of Salome V8_4_0 in /home/csmdakota/salome/Salome-V8_4_0-univ ...

Verifying archive integrity...

All good.

Done                                                                               

./create_appli.sh: line 108: /salome_prerequisites.sh: No such file or directory

./create_appli.sh: line 109: /salome_modules.sh: No such file or directory

Creating Salome application in /home/csmdakota/salome/appli_V8_4_0 ...

sed: can't read /.config_appli_template.xml: No such file or directory

grep: salome_context.cfg: No such file or directory

Salome post-installation ...

Warning: the directory /home/csmdakota/OpenFOAM/ThirdParty-v1712/platforms/linux64Gcc/gperftools-2.5/lib64 is in a path variable but does not exist

Warning: the directory /home/csmdakota/OpenFOAM/csmdakota-v1712/platforms/linux64GccDPInt32Opt/lib is in a path variable but does not exist

Warning: the directory /home/csmdakota/OpenFOAM/site/v1712/platforms/linux64GccDPInt32Opt/lib is in a path variable but does not exist

Warning: the directory /home/csmdakota/OpenFOAM/ThirdParty-v1712/platforms/linux64Gcc/gperftools-2.5/bin is in a path variable but does not exist

Warning: the directory /home/csmdakota/OpenFOAM/site/v1712/platforms/linux64GccDPInt32Opt/bin is in a path variable but does not exist

./create_appli.sh: line 295: ./salome_post_install.py: No such file or directory

The Salome application was successfully created.

To run the application:

$ /home/csmdakota/salome/appli_V8_4_0/salome

The four files names that I highlighted I can actually find after the install process in the $home/csmdakota/salome/Salome-V8_4_0-univ directory.  The config_apli_template.xml I cannot find.
 
When I try to run the program via , I receive "salome: command not found". 
 
There are only two files under the /appli_V8_0 directory, a blank config_appli.xml file and a appli_V8_4_0.log file which has 1 line of code:
 ./create_appli.sh: line 132: python: command not found
Line 132 in create_appli.sh is the following:
python "${KERNELDIR}"/bin/salome/appli_gen.py > appli_V8_4_0.log 2>&1
 
Is there anything obvious or otherwise that I am missing or doing wrong?
 
Thanks in advance,
CSMDakota
 

Re: Install From Binaries: Ubuntu 17.10

Posted by CSMDakota at May 14. 2018

Update: I updated to Ubuntu 18.04 LTS and tried again - the install seems to have worked this time, at least partially.  When I launch salome I get the same warnings reported in this link: http://www.salome-platform.org/forum/forum_14/1750017#827893820 

I'm going to start exploring the program and see if I notice any ill-effects from these warnings.

Powered by Ploneboard
Document Actions