Personal tools
You are here: Home Forum Install & build Error running Salome 7.8.0 on Kubuntu 14.04

Error running Salome 7.8.0 on Kubuntu 14.04

Up to Install & build

Error running Salome 7.8.0 on Kubuntu 14.04

Posted by Antonio Soares at January 23. 2017

Greetings,

 

I'm having trouble running Salome 7.8.0 on Kubuntu 14.04. I never had problems on Ubuntu, but Kubuntu seems to have some slight differences beyond aesthetics which make certain programs hard run without further configuration.

 

when going to the root folder and running './salome' I get the following error message:

 

[QUOTE]

Searching for a free port for naming service: 2814 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++Traceback (most recent call last):
  File "/home/pc4/Programs/SALOME-7.8.0-OPENSOURCE-UB14/INSTALL/KERNEL/bin/salome/runSalome.py", line 620, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/pc4/Programs/SALOME-7.8.0-OPENSOURCE-UB14/INSTALL/KERNEL/bin/salome/runSalome.py", line 565, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/pc4/Programs/SALOME-7.8.0-OPENSOURCE-UB14/INSTALL/KERNEL/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 31799 for /Kernel/Session not found

[/QUOTE]

 

It tries this twice then quits.

 

Any ideas?

Re: Error running Salome 7.8.0 on Kubuntu 14.04

Posted by Antonio Soares at January 23. 2017

OK, I'm an idiot and was trying to run the binaries directly instead of installing from the universal binaries...

 

Problem solved. :)

Re: Error running Salome 7.8.0 on Kubuntu 14.04

Posted by Thouraya Nouri Baranger at November 10. 2017

Dear Antonio, how did you do to solve this problem.

II have the same issue on fedora 26 with salomemeca, hereafter the messages

runSalome running on sinople
Searching for a free port for naming service: 2811 - OK
Searching Naming Service + found in 0.1 seconds
Searching /Kernel/Session in Naming Service ++++++++++++++++++++++++Traceback (most recent call last):
  File "/home/softs/salome/appli_V2017.0.2/bin/salome/runSalome.py", line 625, in useSalome
    clt = startSalome(args, modules_list, modules_root_dir)
  File "/home/softs/salome/appli_V2017.0.2/bin/salome/runSalome.py", line 570, in startSalome
    session=clt.waitNSPID("/Kernel/Session",mySessionServ.PID,SALOME.Session)
  File "/home/softs/salome/V2017.0.2/modules/KERNEL_V8_3_0/bin/salome/orbmodule.py", line 174, in waitNSPID
    raise RuntimeError, "Process %d for %s not found" % (thePID,theName)
RuntimeError: Process 3691 for /Kernel/Session not found


--- Error during Salome launch ---

Best regards

Previously Antonio Soares wrote:

OK, I'm an idiot and was trying to run the binaries directly instead of installing from the universal binaries...

 

Problem solved. :)

 

Powered by Ploneboard
Document Actions