Personal tools
You are here: Home Forum Use Adding faces to create a group is taking very long time.

Adding faces to create a group is taking very long time.

Up to Use

Adding faces to create a group is taking very long time.

Posted by sheaker at August 29. 2017
Hello again dear Salome users. I'm using Salome 7.5.1 64bit under Windows 7 64bit, i3@4160. I prepared 2D planar geometry and mesh it. There was over 150 000 faces. The mesh was extruded (1 step) to create 2D mesh for openFoam (3D mesh with 1 cell in Z direction). The mesh contains over 300 000 faces. When I'm trying to create group of faces containing almost all of over 300 000 faces, Salome is freezing for unacceptable long time (I believe it is over several hours. I hadn't enough patience.). Selecting 10 000 faces and adding them (manual select) to group takes about 25 min. I wonder if it is normal for Salome or is there something wrong with my installation or settings? Have a nice day. Sheaker

Re: Adding faces to create a group is taking very long time.

Posted by Saint Michael at August 29. 2017

Hi

This is a know "feature" :) of group dialog. http://docs.salome-platform.org/latest/gui/SMESH/grouping_elements_page.html

It is more practical to create groups either on geometry or on filter.

St.Michael

Re: Adding faces to create a group is taking very long time.

Posted by sheaker at August 29. 2017
Hello St.Michael. Thank You again for sharing Your knowledge! I think it could be hard to create group on geometry because the final mesh is a compound of few meshes and of course few separate geometrical objects. If it shouldn't be so hard then I will definitely try it. I have just checked "Group type: Group on filter" and it works in no time. I can't find filter with "direction of normal to face". I found "coplanar faces" but it doesn't work as it should, I think. Could You possibly help me again with this? My procedure creating group is listed below: 1. 'Create group' 2. set 'Faces' 3. set 'group on filter' 4. 'Set Filter' 5. add 6. set 'coplanar filter' in criterion tab. 6. click on 'Threshold value' 7. select one face on the side with faces I want to add to group. 8. optional: 'set tolerance' to 1e-4 9. 'Apply and close'(set filter) 10. 'Apply and close' (create group) ... and not all faces on selected side are in the created group. I think that this is a mesh compound bug (or bad usage) but I'm not sure. But even if I could select all faces on the one side I can not succeed with both side at once. No 'add' nor 'insert' works. Thank You again for Your patience. Unfortunately there will be more questions sooner or later. I don't want to 'flood' the forum. Have a nice day. Sheaker

Re: Adding faces to create a group is taking very long time.

Posted by Saint Michael at August 29. 2017

I think 'coplanar faces' does not work because your mesh is a compound, and 'coplanar faces' selects only neighbors of a selected face. But you can add to a filter as many 'coplanar faces' as needed (by repeating "5. add" and setting Binary=OR) to select all needed faces.

St.Michael

Re: Adding faces to create a group is taking very long time.

Posted by Saint Michael at August 29. 2017

By the way tolerance = 1e-4 degrees may be too small.

Re: Adding faces to create a group is taking very long time.

Posted by sheaker at August 29. 2017

I didn't know there is an option to change "AND" to "OR"! It works now! Thank You so much!

About my compound mesh:

There were 11 part of mesh and 8 of them had same color and other 3 had other color. The same color set was in geometry module so I think 8 parts of geometry had different properties than other three parts that's why I was unable to coplanar them with one criteria.

About the tolerance:

I was just trying to lower the tolerance a bit

Thank You again.

Sorry for the bad formatting.

Have a nice day.

Sheaker

Powered by Ploneboard
Document Actions